string matching (expand KMP)

Problem Description
String matching is a common type of problem in computer science. One string matching problem is as following:

Given a string  s[0len1], please calculate the length of the longest common prefix of s[ilen1] and s[0len1] for each i>0.

I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:



We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.
 

 

Input
The first line contains an integer  T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.

1T30

* string length 106 for every string
 

 

Output
For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.
 

 

Sample Input
3 _Happy_New_Year_ ywwyww zjczzzjczjczzzjc
 

 

Sample Output
17 7 32
Code:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<vector>
#include<cmath>

const int maxn=1e6+5;
typedef long long ll;
using namespace std;

ll ans;
void pre_EKMP(char x[],int m,ll next[])
{
    next[0]=m;
    int j=0;
    while(j+1<m&&x[j]==x[j+1])
    {
        j++;
    }

    next[1]=j;
    int k=1;
    for(int i=2;i<m;i++)
    {
        int p=next[k]+k-1;
        int L=next[i-k];
        if(i+L<p+1)next[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<m&&x[i+j]==x[j])j++;
        
            next[i]=j;
            k=i;
        }
    }
}

char str[10*maxn];
ll nxt[10*maxn];
int main()
{
    int T;
    cin>>T;
    
    while(T--)
    {
        scanf("%s",str);
        int len=strlen(str);
        ans=0;
    
        pre_EKMP(str,len,nxt);
        for(int t=1;t<len;t++)
        {
            if(nxt[t]+t<len)
            {
              ans+=(nxt[t]+1);
            }
            else
            {
                ans+=(len-t);
            }
        }
    //    ll ans=0;
    printf("%lld\n",ans);
    }
    return 0;
}

 

 

Guess you like

Origin www.cnblogs.com/Staceyacm/p/11305505.html