The 2017 ACM-ICPC Asia Beijing Regional E - Cats and Fish

思维题,模拟猫吃鱼的过程就出来了~~~~

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input
There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn, ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output
For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input
2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1
Sample Output
1 0
0 1
0 3

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	int m, n, x;
	while (scanf("%d%d%d", &m, &n, &x) != EOF){
		int time[110] = { 0 };//每只猫吃一条鱼花费的时间
		for (int i = 0; i < n; i++){cin >> time[i];}
		sort(time, time + n);//因为按照吃鱼所花费的时间优先级分配鱼,所以要排序
		int ti = 0,li=m;//ti表示时间,li表示还剩的鱼个数
		int left[110] = { 0 };//每个时刻每只猫需要吃完一条鱼的剩余时间
		if (m < n){ n = m; }//如果鱼的个数小于猫的个数,则每只猫不会都有鱼吃
		for (int i = 0; i < n; i++){ left[i] = time[i];}//0时刻每只猫吃一条鱼的时间
		li -= n;//假设刚开始每只猫都有一条鱼吃
		while (ti < x+1){
			for (int i = 0; i < n; i++){//每过一分钟后,每只猫,吃一条鱼的时间
				left[i]--;
			}
			ti++;
			if (ti < x){//第i分钟时,一只猫是否可以重新得到一条鱼
				for (int i = 0; i < n; i++)
				if (left[i] <= 0){//一只猫吃完了一条鱼
					if (li > 0){//还有多余的鱼,可以分配给这只已经吃完鱼的猫
						left[i] = time[i];
						li--;
					}
				}
			}
		}

		//统计数组中大于0的个数就是剩余的不完整鱼的个数
		int q = 0;
		for (int i = 0; i < n; i++){
			if (left[i] >= 0){
				q++;
			}
		}

		//li就是剩余的完整鱼的个数
		if (li < 0){ li = 0; }
		cout << li << " " << q << endl;
	}
	return 0;
}
发布了87 篇原创文章 · 获赞 73 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/HL_HLHL/article/details/84308877