hdu 2019 数列有序!

Problem Description

有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。

Input

输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。

Output

对于每个测试实例,输出插入新的元素后的数列。

Sample Input

3 3
1 2 4
0 0

Sample Output

1 2 3 4
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

int a[maxn];

int main(){

    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==m&&m==0)break;
        int j=0;
        int nn=n;
        int o=0;
        while(nn--){
            int b;
            scanf("%d",&b);
            if(b>=m&&!o){
                a[j++]=m;
                o=1;
            }
            a[j++]=b;
        }
        if(j==n)a[j++]=m;
        printf("%d",a[0]);
        for(int i=1;i<j;i++){
            printf(" %d",a[i]);
        }printf("\n");
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wz-archer/p/12430682.html