HDU2019 数列有序!【基础题】【简单排序】

数列有序!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 105780    Accepted Submission(s): 44178


Problem Description
有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。
 

Input
输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。
 

Output
对于每个测试实例,输出插入新的元素后的数列。
 

Sample Input
 
  
3 3 1 2 4 0 0
 

Sample Output
 
  
1 2 3 4
 AC代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
int main(void)
{
	int n,k;
	while(~scanf("%d%d",&n,&k))
	{
		
		int a[n+1];
		if(n==0&&k==0)
			break;
		for(int i = 0; i < n; i++)
		{
			scanf("%d",&a[i]);
		}
		a[n] = k;
		sort(a,a+(n+1));
		for(int i = 0; i < n; i++)
			printf("%d ",a[i]);
		printf("%d\n",a[n]);
	}
	return 0;
}


 

猜你喜欢

转载自blog.csdn.net/wxd1233/article/details/80381299