寒假私训——并查集 D - E - A Bug's Life(进阶)

题目要求

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint
Huge input,scanf is recommended.

解题思路

此题和前一题没啥区别,答题思路一样,就是输出有点别扭,一定要注意一个样例结束后要打印空格,不然会Presentation Error。

代码

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 1000100
using namespace std;

 int f[maxn],rank[maxn];

 int find(int x){
     if(x==f[x]){
         return x;
     }
     int rx=f[x];
     f[x]=find(f[x]);
     rank[x]=(rank[x]+rank[rx])%2; //压缩路径
     return f[x];
 }

 void add(int x,int y){
     int rx=find(x);
     int ry=find(y);
     if(rx!=ry){
         f[ry]=rx;
         rank[ry]=(rank[x]+rank[y]+1)%2;
     }
 }

 int main(){
     int t,i;
     scanf("%d", &t);
     for(i=1;i<=t;i++){
         int n,m;
         scanf("%d%d",&n,&m);
         for(int i=1; i<=n; i++){
             f[i] = i;
             rank[i] = 0;
         }
         bool flag=0;
         while(m--){
             int x, y;
             scanf("%d%d",&x,&y);
             int f1=find(x);
             int f2=find(y);
             if(f1!=f2){
                 add(x, y);
             }else{
                     if(rank[x]==rank[y]){
                         flag=1;
                     }
             }
         }
         printf("Scenario #%d:\n",i);
         if(flag==1)
               printf("Suspicious bugs found!\n");
         else
               printf("No suspicious bugs found!\n");
         printf("\n");
     }
     return 0;
 }
发布了36 篇原创文章 · 获赞 1 · 访问量 1388

猜你喜欢

转载自blog.csdn.net/atnanajiang/article/details/104120538