POJ 2494 A Bug's Life 并查集变形

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意:

求虫群中是否含有同性恋。

思路:

一边建立关系, 一边进行判定,建立一个数组a,表示元素之间的关系,再建一个数组b,表示与根节点的关系。

然后在查找和合并里更新b中的值,这里用到向量。即在合并中b[temp1]=(1+b[y]-b[x])%2,temp1为x的根节点。画个有向图就能看出来。在查找中:b[x]=(b[x]+b[temp])%2;temp为x的父节点.

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=2005;
int a[maxn];
int is[maxn];
int finds (int x)
{
    int par;
    if(x==a[x])
        return x;
    int temp=a[x];
    par=finds(a[x]);
    a[x]=par;
    is[x]=(is[x]+is[temp])%2;
    return par;
}
int main()
{
    int n;
    scanf("%d",&n);
    int flag=0;
    for (int j=1;j<=n;j++)
    {
        flag=0;
        int m,k;
        scanf("%d%d",&m,&k);
        for (int i=1;i<=m;i++)
        {
            a[i]=i;
            is[i]=0;
        }
        for (int i=0;i<k;i++)
        {
            int xx,yy;
            scanf("%d%d",&xx,&yy);
            if(!flag)
            {
                int temp1=finds(xx);
                int temp2=finds(yy);
            if(temp1==temp2&&is[xx]==is[yy])
             {
                flag=1;
             }
            else
             {
                 a[temp1]=temp2;
                 is[temp1]=(is[yy]-is[xx]+1)%2;
             }
            }
        }
        printf("Scenario #%d:\n",j);
        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        printf("\n");

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81546309