POJ 2492 A Bug's Life 带权并查集

一、内容

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it. 

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one. 

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong. 

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint
Huge input,scanf is recommended.

二、思路

在这里插入图片描述

三、代码

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 2e3 + 5;
int n, m, t, x, y, p[N], d[N];
int find(int x) {
	if (x == p[x]) return x;
	int root = find(p[x]);
	d[x] += d[p[x]];
	p[x] = root;
	return p[x];
}
int main() {
	int T = 1;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d", &n, &m);
		for (int i = 1; i <= n; i++) p[i] = i, d[i] = 0;
		bool ok = true;
		for (int i = 1; i <= m; i++) {
			scanf("%d%d", &x, &y);
			if (!ok) continue; 
			int fx = find(x), fy = find(y);
			if (fx != fy) {
				//进行合并
				p[fx] = fy; d[fx] = d[y] - d[x] + 1; 
			} else {
				//判断是否是同类
				if ((d[x] - d[y]) % 2 == 0) ok = false; //代表是同类 错误 
			}
		}
		printf("Scenario #%d:\n", T++); 
		if (ok) printf("No suspicious bugs found!\n\n");
		else printf("Suspicious bugs found!\n\n"); 
	}
	return 0;
} 
发布了484 篇原创文章 · 获赞 494 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104608805