SDNU_ACM_ICPC_2020_Winter_Practice_2nd J树状数组

题目

N个气球排成一排,从左到右依次编号为1,2,3…N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
Sample Output
1 1 1
3 2 1

思路

利用update(a,1);///a~n +1 update(b+1,-1);///b+1~n -1
来使区间a~b之间的值加一

代码

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
int n;
int a[100005],c[100005];///原数组,树状数组
int lowbit(int x)
{
    return x&(-x);
}
void update(int i,int k)///在i位置上加k
{
    while(i<=n)
    {
        c[i]+=k;
        i+=lowbit(i);
    }
}
int getsum(int i)///区间和
{
    int res=0;
    while(i>0)
    {
        res+=c[i];
        i-=lowbit(i);
    }
    return res;
}
int main()
{
    while(cin>>n &&n!=0)
    {
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        int a,b;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            update(a,1);///a~n  +1
            update(b+1,-1);///b+1~n  -1
        }
        for(int i=1;i<n;i++)
        {
            printf("%d ",getsum(i));
        }
        cout<<getsum(n)<<endl;
    }
    return 0;
}
发布了46 篇原创文章 · 获赞 0 · 访问量 1159

猜你喜欢

转载自blog.csdn.net/weixin_45719073/article/details/104077705