SDNU_ACM_ICPC_2020_Winter_Practice_2nd D拓扑排序

题目

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

思路

拓扑排序

代码

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<cmath>
#include <queue>
using namespace std;
typedef long long ll;
//const int inf = 0x3f3f3f3f;
int du[208];///入度
int t[207][207];///图
void topo(int n)
{
    int k;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(du[j]==0)///入度为0的点
            {
                cout<<j;
                du[j]--;
                k=j;
                break;
            }
        }
        for(int j=1;j<=n;j++)
        {
            if(t[k][j]==1)
            {
                t[k][j]=0;///标记
                du[j]--;
            }
        }
        if(i<n)
            cout<<" ";
    }
}
int main()
{
    int n,m;
    while(cin>>n>>m&&(n!=0||m!=0))
    {

        for(int i=0;i<m;i++)
        {
            int u,v;
            cin>>u>>v;
            if(t[u][v]==0)
            {
                t[u][v]=1;
                du[v]++;
            }
        }
        topo(n);
        cout<<endl;
        memset(du,0,sizeof(du));
        memset(t,0,sizeof(t));
    }
    return 0;
}


发布了46 篇原创文章 · 获赞 0 · 访问量 1141

猜你喜欢

转载自blog.csdn.net/weixin_45719073/article/details/104314810