[kuangbin带你飞]专题十二 基础DP1 F - Piggy-Bank HDU - 1114(完全背包)

F - Piggy-Bank HDU - 1114(完全背包)

题目链接:https://vjudge.net/contest/68966#problem/F

题目:

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

InputThe input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
OutputPrint exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题意:首先第一行输入测试次数,然后每个测试用例第一行都包含空存钱罐的重量和装满钱时候存钱罐的重量,然后第二行输入现有的钱的种类,后面就是每种钱的价值和钱的重量。要求用存钱罐中钱的重量来找到存钱罐中的最低金额,如果可以找到那么打印“ The minimum amount of money in the piggy-bank is X.”,其中X是使用给定总重量的硬币可以达到的最低金额。如果不能准确地达到重量,This is impossible.”。
思路:完全背包问题,其详细知识点可戳链接:https://www.cnblogs.com/DJC-BLOG/p/9418438.html

//
// Created by hanyu on 2019/8/4.
//
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
#include<math.h>
#include<map>
using namespace std;
typedef long long ll;
const int maxn=1e5+7;
#define MAX 0x3f3f3f3f
int main()
{
    int n;
    scanf("%d",&n);
    while(n--) {
        int a[maxn],b[maxn],dp[maxn];
        memset(dp,MAX,sizeof(dp));
        dp[0]=0;
        int e,f;
        scanf("%d%d",&e,&f);
        int weight=f-e;
        int m;
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&a[i],&b[i]);//a价值,b重量

        }
        for(int i=1;i<=m;i++)
        {
            for(int j=b[i];j<=weight;j++)
            {
                dp[j]=min(dp[j],dp[j-b[i]]+a[i]);
            }
        }
        if(dp[weight]==MAX)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[weight]);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Vampire6/p/11300743.html