PAT 甲级 1032 Sharing (25分)测试点三坑

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

解题思路:本题数据量不大通过静态链表操作,不可用暴力搜索来做。首先从第一个字符的起始地址遍历将遍历到的flag置1,再通过第二个字符的起始地址开始遍历若结构体中flag为1说明找到了开始相同的第一个字母所在位置。

代码:

#include<cstdio>
struct node
{
	char a;
	int next;
	int flag;
}Node[100010];
int main(void)
{
	int N,temp1,temp2,tempnum,tempnext;
	char a;
	scanf("%d %d %d",&temp1,&temp2,&N);
	while(N--)
	{
		scanf("%d %c %d",&tempnum,&a,&tempnext);
		Node[tempnum].a = a;
		Node[tempnum].next = tempnext;
		Node[tempnum].flag = 0;
	}
	int p = temp1; 
	while(p != -1)
	{
		Node[temp1].flag = 1;
		temp1 = p;
		p = Node[p].next;
	}
	p = temp2;
	while(p != -1)
	{
		if(Node[temp2].flag == 1)
		{
			printf("%05d",temp2);
			return 0;
		}
		else
		{
			temp2 = p;
			p = Node[p].next;
		}
			
	}
	printf("-1");
	return 0;
}

第三个测试点不通过是因为循环结束的条件有问题,一开始我循环才用如下代码测试点三不通过。因为最后一个结构体没有遍历到。

	while(Node[temp1].next!=-1)
	{
		Node[temp1].flag = 1;
		temp1 = Node[temp1].next;
	}
	while(Node[temp2].next!=-1)
	{
		if(Node[temp2].flag == 1)
		{
			printf("%05d",temp2);
			return 0;
		}
		else
		    temp2 = Node[temp2].next;
	}

发布了24 篇原创文章 · 获赞 1 · 访问量 503

猜你喜欢

转载自blog.csdn.net/lovingcgq/article/details/104382549