10-排序6 Sort with Swap(0, i)

Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N () followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

#include<stdlib.h>
#include<stdio.h>

int main()
{
	int a[100000];
	int b[100000] = { 0 };
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &a[i]);
	}
	int cnt = 0;	//记录环数
	int rp = 0;		//记录步数
	
	for (int i = 0; i < n; i++)
	{
		if (a[i] == i) {
			b[i] = 1;
		}
	}
	for (int i = 0; i < n; i++)
	{
		if (a[i] != i && b[i] != 1) {
			cnt++;
			int qidian = a[i];
			do
			{
				rp += 1;
				b[a[i]] = 1;
				i = a[i];
			} while (a[i] != qidian);
		}
	}


	if (a[0] != 0) {
		if (cnt == 0) {
			printf("0");
		}else{
			printf("%d", cnt - 2 + rp);
		}
		
	}
	else {
		if (cnt == 0) {
			printf("0");
		}
		else {
			printf("%d",  cnt + rp );
		}
	}
	
	system("pause");
    return 0;

}


猜你喜欢

转载自blog.csdn.net/qq_29718605/article/details/80291839