PTA(Advanced Level)1067.Sort with Swap(0, i)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9
思路
  • 贪心策略:
    • 最好的置换结果就是一次就把数字还原到最后对应的位置上去
    • 可能出现的结果是0在不断置换的过程中回到了0的位置,但是整个数组仍非有序的,此时0要是和已经归位的数字发生替换那么就会多出步数,此时应该和还没归位的数字换位置
代码
#include<bits/stdc++.h>
using namespace std;
int a[100010];
int main()
{
    int n;
    cin >> n;
    for(int i=0;i<n;i++)    cin >> a[i];
    int remain = 0;
    for(int i=0;i<n;i++)
        if(a[i] != i && a[i] != 0)
            remain++;
    int k = 1;    //表示下一个0该跳转的位置(如果0跳到0上)
    int ans = 0;
    while(remain > 0)
    {
        if(a[0] == 0)    //0在本位上
        {
            while(k < n)
            {
                if(a[k] != k)   //找到第一个不在该在的位置上的数字
                {
                    swap(a[0], a[k]);
                    ans++;
                    break;
                }
                k++;
            }
        }

        while(a[0] != 0)    //当0不在0号位的时候
        {
            swap(a[0], a[a[0]]);   //将0所在位置上的数和0进行交换
            ans++;
            remain--;
        }
    }
    cout << ans;
    return 0;
}

引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805403651522560

猜你喜欢

转载自www.cnblogs.com/MartinLwx/p/11979842.html