1067 Sort with Swap(0, i)(25 分)

1067 Sort with Swap(0, i)(25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

思路,数组最后的结果是值与下标相等,所以在排的过程中,varr[0] 与 varr[ varr[0] ] 交换,使得 varr[ varr[0] ] 是值与下标相等。 varr[ 0 ] 得到 varr[ varr[0] ] 的值, 重复进行直到 varr[0] = 0.

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
using namespace std;
void swap(int& a, int& b);
void sent(vector<int>& varr);
int num = 0;
int main(){
	int n,x;
	vector<int> varr;
	cin >> n;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		varr.push_back(x);
	}
	for (int i = 0; i < n; ++i) {
		if (varr[i] != i) {
			swap(varr[0], varr[i]);
			if (i != 0) num++;
			sent(varr);
		}
	}
	cout << num << endl;
	system("pause");
	return 0;
}
void sent(vector<int>& varr) {
	while (varr[0] != 0) {
		swap(varr[0], varr[varr[0]]);
		num++;
	}
}
void swap(int& a, int& b) {
	int x = a;
	a = b; b = x;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82250519