【C语言做题系列】A Simple Task

Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example

For n = 24, o = 3 and p = 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.
Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
Sample Input
1
24
Sample Output
3 3
题意:
输入的第一行正好包含一个正整数d,它等于数据集的数量,1 <= d <= 10。为每个数据写一个程序:读取一个正整数n,计算奇数o和非负整数p使得n = o*2^p。

注意:
此题有限制,若用遍历的方法时间复杂度可能超出限制。

算法思想:
输入的n不断除以二,p用来计算除的次数,直到n为奇数为止,最后剩下的n和p就是题目要求的o和p。

上代码:

#include <stdio.h>
int main()
{
   int d;int n, o, p;
   scanf("%d", &d);
   while(d--)
   {
      if(d<1&&d>10)           //题目中有规定d的范围,所以这点需要注意
        break;
       scanf("%d", &n);
       p=0;
       while(n%2==0)          //此为此题的精髓,需要多多理解
       {
           p++;               //n除以一次2,指数p就自增一次
           n/=2;
       }
       printf("%d %d\n", n, p); //两个输出之间有一个空格
   }
   return 0;
}

心得:
不是任何这种类似的问题都要用“遍历”,要学会变通。

发布了16 篇原创文章 · 获赞 0 · 访问量 449

猜你喜欢

转载自blog.csdn.net/qq_45627679/article/details/104291718