POJ - 3096 Surprising Strings

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.
Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.
Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.
Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

//**题意:**给你一个串,把它分成若干个子串,每个子串长度为2,然后子串的第一个和第二个在原串中相隔n(0,1,2…)然后让你去判断,这个相隔n的长度为2的子串中有没有相同的。

C++编译错误:G++是AC,哪位大佬能指点一下。

#include<stdio.h>
#include<map>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;

map<string,int>m;
char s1[500],s[500];
int main(void)
{
	while(1){
		scanf("%s",s);
		int flag=0;
		if(s[0]=='*')
			break;
		int n;
		n=strlen(s);
		for(int i=0;i<n;i++){	
			for(int j=0;j+i+1<n;j++){
				s1[0]=s[j];
				s1[1]=s[j+i+1];//相隔n
				s1[2]='\0';
				m[s1]++;
				if(m[s1]>1){
					cout<<s<<" "<<"is NOT surprising."<<endl;
					flag=1;
					break;
				}
			}
			m.clear();//判断后清除上一个间隔为n的子串
			if(flag==1)
				break; 
		}
		if(flag==0)
			cout<<s<<" "<<"is surprising."<<endl;
	} 
	return 0;
}
发布了53 篇原创文章 · 获赞 1 · 访问量 1342

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/102987082
今日推荐