Power Strings POJ - 2406

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
KMP的板子题
求循环节

#include <string.h>
#include <stdio.h>
#include <stdlib.h>

int main()
{
    char* s = (char *)malloc(sizeof(char) * 1e7 + 1);

    while(scanf("%s",s) != EOF)
    {
        if(strcmp(s,".") == 0)
            break;
        int* next = (int *)malloc(sizeof(int) * 1e7);
        int len = strlen(s);
        int i = 0,j = -1;
        next[0] = -1;
        while(i < len)
        {
            if(j == -1 || s[i] == s[j])
            {
                i++;
                j++;
                next[i] = j;
            }
            else
                j = next[j];
        }
        int repetend = len - next[len];
        if(len % repetend == 0)
        printf("%d\n",len / repetend);
        else
            printf("1\n");
        free(next);
    }
    free(s);
    return 0;
}


发布了39 篇原创文章 · 获赞 4 · 访问量 5749

猜你喜欢

转载自blog.csdn.net/weixin_45725137/article/details/105321510