Building bridges 4584(数组简化法)

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Problem Description

Hululu and Cululu are two pacific ocean countries made up of many islands. These two country has so many years of friendship so they decide to build bridges to connect their islands. Now they want to build the first bridge to connect an island of Hululu and an island of Culuu .
Their world can be considered as a matrix made up of three letters ‘H’,‘C’ and ‘O’.Every ‘H’ stands for an island of Hululu, every ‘C’ stands for an island of Cululu, and ‘O’ stands for the ocean. Here is a example:

The coordinate of the up-left corner is (0,0), and the down-right corner is (4, 3). The x-direction is horizontal, and the y-direction is vertical.
There may be too many options of selecting two islands. To simplify the problem , they come up with some rules below:

  1. The distance between the two islands must be as short as possible. If the two islands’ coordinates are (x1,y1) and (x2,y2), the distance is |x1-x2|+|y1-y2|.
  2. If there are more than one pair of islands satisfied the rule 1, choose the pair in which the Hululu island has the smallest x coordinate. If there are still more than one options, choose the Hululu island which has the smallest y coordinate.
    3.After the Hululu island is decided, if there are multiple options for the Cululu island, also make the choice by rule 2.
    Please help their people to build the bridge.

Input

There are multiple test cases.
In each test case, the first line contains two integers M and N, meaning that the matrix is M×N ( 2<=M,N <= 40).
Next M lines stand for the matrix. Each line has N letters.
The input ends with M = 0 and N = 0.
It’s guaranteed that there is a solution.

Output

For each test case, choose two islands, then print their coordinates in a line in following format:
x1 y1 x2 y2
x1,y1 is the coordinate of Hululu island, x2 ,y2 is the coordinate of Cululu island.

Sample Input

4 4 CHCH HCHC CCCO COHO 5 4 OHCH HCHC CCCO COHO HCHC 0 0

Sample Output

0 1 0 0 0 1 0 2

本题提交网址

http://acm.hdu.edu.cn/showproblem.php?pid=4584

题意分析

利用四维数组的下角标分别对应x1,x2,y1,y2的值存储,四维数组本身的值为桥的跨度和

代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
int a[41][41][41][41];
int main()
{
    int n,m,min,mini,minj,mink,minl;
    char c[41][41];
    while((cin>>n>>m)&&(n||m))
    {
        getchar();
        min=100000000;
        memset(a,-1,sizeof(a));
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin>>c[i][j];
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                for(int k=0; k<n; k++)
                    for(int l=0; l<m; l++)
                        if(c[i][j]=='H'&&c[k][l]=='C')
                            a[i][j][k][l]=abs(i-k)+abs(j-l);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                for(int k=0; k<n; k++)
                    for(int l=0; l<m; l++)
                        if(a[i][j][k][l]!=-1&&a[i][j][k][l]<min)
                        {
                            min=a[i][j][k][l];
                            mini=i;
                            minj=j;
                            mink=k;
                            minl=l;
                        }
        cout<<mini<<" "<<minj<<" "<<mink<<" "<<minl<<endl;
    }
    return 0;
}
发布了27 篇原创文章 · 获赞 16 · 访问量 1967

猜你喜欢

转载自blog.csdn.net/weixin_43899069/article/details/99934571