PAT A1075 PAT Judge (25分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4), the total number of users, K(≤5), the total number of problems, and M (≤10​5), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:
user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:
rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题意:

第一行输入用户数量N、题目数量K、记录数量M,第二行输入每道题目的总分,然后逐行输入用户id、题号、所得分数(-1代表提交了但未通过编译);排序后逐行输出排名、用户id、总分、各小题得分(-表示未提交过,0表示提交但未通过编译(即输入所得分数为-1)或提交编译通过但得分为0).

思路:

(1)开设student结构体数组stu[],包含id、total_score、s[6]、perfect_number、input,其中total_score表示总分、s[1]~s[5]表示各小题所得分、perfect_number表示得分为满分的题目个数(作为cmp函数的参考依据),input为true或false代表学生信息是否可以输出(一旦输入某题所得分数不为-1就令input=true允许输出);
(2)初始化stu[]时,令s[1]~s[5]为-1,当输入某题分数为-1时,表示该题提交了但编译没有通过,计为0分.

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct student{
	int id,total_score,s[6],perfect_number;
	bool input;
}stu[10010];
bool cmp(student a,student b){
	if(a.input!=b.input) return a.input>b.input;//true>false,先输出能编译的 
	else if(a.total_score!=b.total_score) return a.total_score>b.total_score;
	else if(a.perfect_number!=b.perfect_number) return a.perfect_number>b.perfect_number;
	else return a.id<b.id;	
}

int main(){
	int N,K,M;
	scanf("%d %d %d",&N,&K,&M);
	int full[6];
	for(int i=1;i<=K;i++){
		scanf("%d",&full[i]);
	}
	for(int i=1;i<=N;i++){//初始化stu[] 
		stu[i].id = i;//考生编号按序编制 
		stu[i].total_score = 0;//总分 
		stu[i].perfect_number = 0;//拿满分的题目数 
		stu[i].input = false;//是否输出 
		memset(stu[i].s,-1,sizeof(stu[i].s));//各小题分数,-1代表未提交过 
	}
	int user_id,pro_id,par_score;//用户id,题号,对应得分 
	for(int i=0;i<M;i++){
		scanf("%d %d %d",&user_id,&pro_id,&par_score);
		//一道题也没有提交 和 提交了但一道题也没有通过编译的情况下s[i]的值都为-1,所以:
		if(par_score!=-1){//一旦有编译通过的提交(得分不为-1) 
			stu[user_id].input = true;
		} 
		if(par_score==-1&&stu[user_id].s[pro_id]==-1){//提交但编译未通过,计0分 
			stu[user_id].s[pro_id] = 0;
		}
		if(par_score==full[pro_id]&&stu[user_id].s[pro_id]<full[pro_id]){//满分题目加1 
			stu[user_id].perfect_number++;
		}
		if(par_score>stu[user_id].s[pro_id]){//高分覆盖低分 
			stu[user_id].s[pro_id] = par_score;
		}
	}
	for(int i=1;i<=N;i++){//求总分 
		for(int j=1;j<=K;j++){
			if(stu[i].s[j]!=-1){
				stu[i].total_score+=stu[i].s[j];
			}
		}
	}
	sort(stu+1,stu+N+1,cmp);
	int rank=1;//排名,输出。 
	for(int i=1;i<=N&&stu[i].input==true;i++){
		if(i>1&&stu[i].total_score<stu[i-1].total_score){
			rank = i;
		}
		printf("%d %05d %d",rank,stu[i].id,stu[i].total_score);
		for(int j=1;j<=K;j++){
			if(stu[i].s[j]==-1){
				printf(" -");
			}else{
				printf(" %d",stu[i].s[j]);
			}
		}			
		printf("\n");	
	} 
	return 0;
}

词汇:

compiler 编译器

发布了26 篇原创文章 · 获赞 0 · 访问量 459

猜你喜欢

转载自blog.csdn.net/PanYiAn9/article/details/104259812