PAT Advanced 1075. PAT Judge (25)

问题描述:

1075. PAT Judge (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

这一题要注意区分提交者的类型:

1.未提交或提交不能通过编译的人不能出现在排名表上;

2.那些提交的总分数为0的人,只有当他的提交通过了编译但得分为0时才能出现在排名表上;

3.在排名表上的人,只有未提交的一栏会被打印为-;

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
#include<bits/stdc++.h> 
using namespace std;
struct st
{
	int g;
	vector<int> gx;
	int pf;
	int id;
	bool flag;
	bool operator < (const st& es) const
	{
		if(g!=es.g)
		{
			return g>es.g;
		}
		else if(pf!=es.pf)
		{
			return pf>es.pf;
		}
		else
		{
			return id<es.id;
		}
	}
} s;
int main()
{
//	ios::sync_with_stdio(false);
  //	freopen("data.txt","r",stdin);
  	int n,k,m,x,xg,xid;
  	scanf("%d %d %d",&n,&k,&m);
  	vector<int> gf(k,-2);
  	s.gx=gf;
  	s.pf=0;
  	s.id=0;
  	s.g=0;
  	s.flag=false;
  	for(int i=0;i<k;i++)
  	{
  		scanf("%d",&xg);
  		gf[i]=xg;
	}
  	vector<st> v(n,s);
  	for(int i=0;i<m;i++)
  	{
  		scanf("%d %d %d",&xid,&x,&xg);
  		v[xid-1].id=xid;
  		if(xg>=0)	v[xid-1].flag=true;
  		if((v[xid-1].gx)[x-1]>0)
  		{
			if((v[xid-1].gx)[x-1]<xg)
			{
  				v[xid-1].g+=(xg-(v[xid-1].gx)[x-1]);					
			}
		}
		else if(xg>0)
		{
			v[xid-1].g+=xg;
		}
  		
  		if((v[xid-1].gx)[x-1]<xg)
  		{
  			(v[xid-1].gx)[x-1]=xg;
  			if(xg==gf[x-1])
  			{
  				v[xid-1].pf++;
			}
		}
	}
	sort(v.begin(),v.end());
	xg=v[0].g;
	int count=1,rank=1;
	for(int i=0;i<n;i++)
	{
		if(v[i].flag)
		{
			if(v[i].g!=xg)	rank=count;
			printf("%d",rank);
			xg=v[i].g;
			printf(" %05d %d",v[i].id,v[i].g);
			for(int j=0;j<k;j++)
			{
				if((v[i].gx)[j]>=0)	printf(" %d",(v[i].gx)[j]);
				else if((v[i].gx)[j]==-1)	printf(" 0");
				else	printf(" -");
			}
			printf("\n");
			count++;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baidu_37550206/article/details/79593822