1075 PAT Judge (25 分)

1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

  这个错误的原因是因为题目啊题目啊 虽然0分但是满足提交的代码 >=0 即可 输出

我这边改了好久

代码:

#include<bits/stdc++.h>
using namespace std;
struct node
{
	int id;
	int mark[7];
	bool flag[7];
	int total;
	bool gg;
	int cnt;
	node(){
		for(int i = 0 ; i <= 6; i ++)
			mark[i] = 0,flag[i] = false; //表示没有提交
		total = 0; 
		cnt = 0;
		id = 0x3f3f3f3f;
		gg = false;
	}
}s[100005];
bool cmp(node a, node b){
	if(a.total != b.total)
		return a.total > b.total;
	else 
	{
		if(a.cnt != b.cnt)
			return a.cnt > b.cnt;
		else 
			return a.id < b.id;
	}
}
int main()
{
	int m, n ,k;
	scanf("%d %d %d", &n, &m, &k);
	int digit[10];
	for(int i = 1; i <= m; i++)
		scanf("%d", &digit[i]);
	int id, pro,sc;
	
	for(int i = 1; i <= k; i++)
	{
		scanf("%d %d %d", &id,&pro,&sc);
		if(sc >= 0)
			s[id].gg = true; 
		s[id].id = id;
		int tmp = s[id].mark[pro];
		s[id].flag[pro] = true;
		s[id].mark[pro] = max(tmp, sc);		
		if(sc > tmp)
			s[id].total = s[id].total - tmp + sc; 
		if(sc == digit[pro] && tmp != digit[pro])
			s[id].cnt ++; 
	}
	sort(s + 1,s + 1 + 99999, cmp);
	s[0].total = s[1].total;
	int ranks = 1, cnt = 0;
	for(int i = 1; i <= 99999; i++)
	{
		if(s[i].gg == true)
		{
			if(s[i].total == s[i - 1].total)
			cnt++;
			else{
				ranks += cnt;
				cnt = 1;
			}	
			
			printf("%d %05d %d",ranks,s[i].id,s[i].total);
			for(int j = 1; j <= m; j++){
				if(s[i].flag[j] == false)
					printf(" -");
				else 
					printf(" %d",s[i].mark[j]);
			}
			printf("\n",s[i].cnt);
		}
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/84449894