破键盘

Sample Input:
They are students.
aeiou
Sample Output:

Thy r stdnts.

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main() {
	//string str1... 因string类只能使用cin输入,无法应对题目个性化输入,所以不常用
	char str1[100], str2[100];
	gets(str1);
	gets(str2);
	for(int i=0; i<strlen(str1); i++) {
		int flag = 0;
		for(int j=0; j<strlen(str2); j++)
			if(str1[i] == str2[j]) {
				flag = 1;
				break;
			}
		if(flag == 0) printf("%c",str1[i]);
	}
	return 0;
}

使用散列优化如下:

#include <cstdio>
#include <cstring>
using namespace std;
int main() {
	bool HashTable[10010];
	char a[100], b[100];
	gets(a);
	gets(b);
	for(int i=0; i<strlen(b); i++)
		HashTable[b[i]] = true;  //下标为ASCII码
	for(int i=0; i<strlen(a); i++)
		if(HashTable[a[i]] == false)
			printf("%c",a[i]);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chushoufengli/article/details/80258009
今日推荐