Dining

题目描述  (传送门

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes.

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

思路:  S -> Food -> 牛 -> 牛0 -> Drinks -> T.   把牛节点拆分!!!

AC代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;
#define IO ios::sync_with_stdio(0), cin.tie(0), cout.tie(0)
#define mset(a, n) memset(a, n, sizeof(a))
#define fi first
#define se second
#define mp make_pair
#define pb push_back
typedef long long ll;
typedef pair<int,int> PII;
typedef pair<int,PII> PPI;
typedef pair<ll, ll> PLL;
const int INF = 0x3f3f3f3f;
const int MOD = 998244353;
const int N_max = 40000+100;

int V, E, S, T, K;
int level[N_max];
int iter[N_max];
struct edge{
    int to,cap,rev;
};
vector<vector<edge> >G;

void add_edge(int from,int to, int cap)
{
    G[from].pb((edge){to,cap,G[to].size()});
    G[to].pb((edge){from,0,G[from].size()-1});
}

/// 计算从源点到每个点的距离
bool bfs(int s){
    mset(level,-1);
    queue<int> Q;
    level[s] = 0;
    Q.push(s);
    while(!Q.empty()){
        int u = Q.front(); Q.pop();
        for(int i = 0; i<G[u].size();i++){
            edge &e = G[u][i];
            if(e.cap>0 && level[e.to]<0){
                level[e.to] = level[u]+1;
                Q.push(e.to);
            }
        }
    }
    if(level[T]==-1) return false;
    else return true;
}
int dfs(int v,int t, int f){
    if(v == t) return f;
    for(int &i = iter[v]; i<G[v].size();i++){
        edge &e = G[v][i];
        if(e.cap>0&&level[v]<level[e.to]){
            int d = dfs(e.to, t, min(f, e.cap));
            if(d>0){
                e.cap -= d;
                G[e.to][e.rev].cap += d;
                return d;
            }
        }
    }
    return 0;
}

int max_flow(int s, int t){
    int flow = 0;
    while(bfs(s)){
        mset(iter, 0);
        int f;
        while ((f = dfs(s,t,INF))>0) flow+=f;

    }
    return flow;
}

int main()
{
    int N, F, D;
    while(~ scanf("%d%d%d", &N, &F, &D)){
        G.clear(); G.resize(2*N+F+D+3);
        S = 2*N+F+D+1, T = 2*N+F+D+2;

        for(int i=1;i<=F;i++){
            add_edge(S, i, 1);
        }
        for(int i=1;i<=N;i++){
            int Fi, Di;
            scanf("%d%d", &Fi, &Di);
            for(int j=1;j<=Fi;j++){
                int f; scanf("%d", &f);
                add_edge(f, F+i, 1);
            }
            for(int j = 1;j<=Di;j++){
                int d; scanf("%d", &d);
                add_edge(F+N+i, F+2*N+d, 1);
            }
        }
        for(int i=1;i<=N;i++){
            add_edge(F+i, N+F+i, 1);
        }
        for(int i=1;i<=D;i++){
            add_edge(F+2*N+i, T, 1);
        }
        int ans = 0;

        ans = max_flow(S, T);

        cout<<ans<<'\n';
    }
    return 0;
}

发布了46 篇原创文章 · 获赞 81 · 访问量 5538

猜你喜欢

转载自blog.csdn.net/zfq17796515982/article/details/102465406