Dining kuangbin

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers:  NF, and  D 
Lines 2..  N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fiintegers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.
Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3


建图  

源点 ----》 食物 -----》 牛-----》牛’-----》饮料------》汇点

边权为一 ,跑最大流。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <functional>
#include <iostream>
#include <queue>
#include <vector>
#include <cmath>
#define inf 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define mp make_pair
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int N = 1e5+50;
const int mod = 1e9+7;
const double pi= acos(-1.0);
typedef pair<int,int>pii;
int n,m,k,f,e,s,t;
int a[150],d[150][150],An=1000;
int num[150][150],cnt,ans;
struct Edge{
    int from,to,cap,flow;
    Edge(int u,int v,int c,int f):from(u),to(v),cap(c),flow(f){}
};
struct Dinic{
    int s,t;
    vector<Edge>edges;
    vector<int> G[N];
    bool vis[N];
    int d[N];
    int cur[N];
    void init(){
       for (int i=0;i<=n+1;i++)
           G[i].clear();
       edges.clear();
    }
    void AddEdge(int from,int to,int cap){
        edges.push_back(Edge(from,to,cap,0));
        edges.push_back(Edge(to,from,0,0));
        int mm=edges.size();
        G[from].push_back(mm-2);
        G[to].push_back(mm-1);
    }
    bool BFS(){
        memset(vis,0,sizeof(vis));
        queue<int>q;
        q.push(s);
        d[s]=0;
        vis[s]=1;
        while (!q.empty()){
            int x = q.front();q.pop();
            for (int i = 0;i<G[x].size();i++){
                Edge &e = edges[G[x][i]];
                if (!vis[e.to] && e.cap > e.flow){
                    vis[e.to]=1;
                    d[e.to] = d[x]+1;
                    q.push(e.to);
                }
            }
        }
        return vis[t];
    }
    int DFS(int x,int a){
        if (x==t || a==0)
            return a;
        int flow = 0,f;
        for(int &i=cur[x];i<G[x].size();i++){
            Edge &e = edges[G[x][i]];
            if (d[x]+1 == d[e.to] && (f=DFS(e.to,min(a,e.cap-e.flow)))>0){
                e.flow+=f;
                edges[G[x][i]^1].flow-=f;
                flow+=f;
                a-=f;
                if (a==0)
                    break;
            }
        }
        return flow;
    }

    int Maxflow(int s,int t){
        this->s=s;
        this->t=t;
        int flow = 0;
        while (BFS()){
            memset(cur,0,sizeof(cur));
            flow+=DFS(s,inf);
        }
        return flow;
    }
}dc;
int main(){
    int a,b,x;
    while(scanf("%d%d%d",&n,&f,&e)==3){
        dc.init();
        s=0;
        t=n*2+f+e+1;
        for (int i=1;i<=f;i++){
            dc.AddEdge(s,i,1);
            dc.AddEdge(i,s,0);
        }
        for (int i=1;i<=e;i++){
            dc.AddEdge(2*n+f+i,t,1);
            dc.AddEdge(t,2*n+f+i,0);
        }
        for (int i=1;i<=n;i++){
            dc.AddEdge(i+f,i+f+n,1);
            dc.AddEdge(i+f+n,i+f,0);
            scanf("%d%d",&a,&b);
            for (int j=1;j<=a;j++){
                scanf("%d",&x);
                dc.AddEdge(x,i+f,1);
                dc.AddEdge(i+f,x,0);
            }
            for (int j=1;j<=b;j++){
                scanf("%d",&x);
                dc.AddEdge(i+f+n,x+n+n+f,1);
                dc.AddEdge(x+n+n+f,i+f+n,0);
            }
        }
        printf("%d\n",dc.Maxflow(s,t));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/acerkoo/article/details/80427630