UVA1585 Score 【基础题】

There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problemand an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself andits just previous consecutive ‘O’s only when the answer is correct. For example, the score of the 10thproblem is 3 that is obtained by itself and its two previous consecutive ‘O’s.

  Therefore, the score of “OOXXOXXOOO” is 10 which is calculated by “1+2+0+0+1+0+0+1+2+3”.

  You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of testcases T is given in the first line of the input. Each test case starts with a line containing a stringcomposed by ‘O’ and ‘X’ and the length of the string is more than 0 and less than 80. There is no spacesbetween ‘O’ and ‘X’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is tocontain the score of the test case.

Sample Input

5

OOXXOXXOOO

OOXXOOXXOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

55

30

题意:一个O代表1,连个连续的O是1,2。以此类推,如果碰到X则重新开始。
AC代码:
#include<stdio.h>
#include<string.h>
#define maxn 80+5
int main(void)
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		char s[maxn];
		scanf("%s",s);
		int len = strlen(s);
		int sum = 0;
		int count = 0;
		for(i = 0; i < len; i++)
		{
			if(s[i]=='O')
			{
				++count;
//				printf("%d\n",count); 
				sum += count;
//				printf("%d\n",sum); 
			}
			if(s[i]=='X')
				count = 0;
		} 
		printf("%d\n",sum);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/wxd1233/article/details/80343926