HDU 5223 GCD

Description:

In mathematics, the greatest common divisor ( g c d gcd ) of two or more integers, when at least one of them is not zero, is the largest positive integer that divides the numbers without a remainder. For example, the GCD of 8 8 and 12 12 is 4 4 .—Wikipedia

BrotherK and Ery like playing mathematic games. Today, they are playing a game with G C D GCD .

BrotherK has an array A A with N N elements: A 1   A N A_{1} ~ A_{N} , each element is a integer in [ 1 , 1 0 9 ] [1, 10^9] . Ery has Q questions, the i-th question is to calculate
G C D ( A L i , A L i + 1 , A L i + 2 , . . . , A R i ) GCD(A_{Li}, A_{Li+1}, A_{Li+2}, ..., A_{Ri}) , and BrotherK will tell her the answer.

BrotherK feels tired after he has answered Q Q questions, so Ery can only play with herself, but she don’t know any elements in array A A Fortunately, Ery remembered all her questions and BrotherK’s answer, now she wants to recovery the array A A .

Input

The first line contains a single integer T T , indicating the number of test cases.

Each test case begins with two integers N , Q N, Q , indicating the number of array A A , and the number of Ery’s questions. Following Q Q lines, each line contains three integers L i , R i L_{i}, R_{i} and Ansi, describing the question and BrotherK’s answer.

T T is about 10 10

2 N Q 1000 2 ≤ N Q ≤ 1000

1 L i < R i N 1 ≤ L_{i} < R_{i} ≤ N

1 A n s i 1 0 9 1 ≤ A_{nsi} ≤ 10^9

Output

For each test, print one line.

If Ery can’t find any array satisfy all her question and BrotherK’s answer, print “Stupid BrotherK!” (without quotation marks). Otherwise, print N N integer, i t h i-th integer is A i A_{i} .

If there are many solutions, you should print the one with minimal sum of elements. If there are still many solutions, print any of them.

Sample Input

2
2 2
1 2 1
1 2 2
2 1
1 2 2

Sample Output

Stupid BrotherK!
2 2

题意:

已知一个序列若干区间内数字的最大公约数,复原出原序列,输出最小满足条件的序列。
初始设序列上所有数字均为1,对每个区间上每个数字,变成原数字与公约数的最小公倍数,最后再检查一次结果序列每个区间是否满足。

AC代码:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
    int ret = 0, sgn = 1;
    char ch = getchar();
    while (ch < '0' || ch > '9')
    {
        if (ch == '-')
            sgn = -1;
        ch = getchar();
    }
    while (ch >= '0' && ch <= '9')
    {
        ret = ret * 10 + ch - '0';
        ch = getchar();
    }
    return ret * sgn;
}
inline void Out(int a) //Êä³öÍâ¹Ò
{
    if (a > 9)
        Out(a / 10);
    putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
    return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(ll a, ll b, ll mod)
{
    if (a >= mod)
        a = a % mod + mod;
    ll ans = 1;
    while (b)
    {
        if (b & 1)
        {
            ans = ans * a;
            if (ans >= mod)
                ans = ans % mod + mod;
        }
        a *= a;
        if (a >= mod)
            a = a % mod + mod;
        b >>= 1;
    }
    return ans;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
    return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
    if (b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    int g = exgcd(b, a % b, x, y);
    int t = x;
    x = y;
    y = t - a / b * y;
    return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
    int d, x, y;
    d = exgcd(a, p, x, y);
    if (d == 1)
        return (x % p + p) % p;
    else
        return -1;
}

///中国剩余定理模板0
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
    int M = 1, y, x = 0;
    for (int i = 0; i < n; ++i) //算出它们累乘的结果
        M *= a[i];
    for (int i = 0; i < n; ++i)
    {
        int w = M / a[i];
        int tx = 0;
        int t = exgcd(w, a[i], tx, y); //计算逆元
        x = (x + w * (b[i] / t) * x) % M;
    }
    return (x + M) % M;
}

ll ans[2122], l[1010], r[1010], a[1011];
int n;

int main()
{
    int t;
    sd(t);
    while (t--)
    {
        int q, flag = 0;
        sdd(n, q);
        rep(i, 1, n)
            ans[i] = 1;
        rep(k, 1, q)
        {
            slddd(l[k], r[k], a[k]);
            rep(i, l[k], r[k])
            {
                ans[i] = lcm(ans[i], a[k]);
                if (ans[i] >= 1e9)
                    flag = 1;
            }
        }
        rep(k, 1, q)
        {
            ll res = ans[l[k]];
            rep(i, l[k] + 1, r[k])
                res = gcd(res, ans[i]);
            if (res != a[k])
                flag = 1;
        }
        if (flag)
            puts("Stupid BrotherK!");
        else
        {
            rep(i, 1, n)
            {
                printf("%lld ", ans[i]);
            }
            cout << endl;
        }
    }
    return 0;
}

发布了611 篇原创文章 · 获赞 390 · 访问量 20万+

猜你喜欢

转载自blog.csdn.net/qq_43627087/article/details/104079771