PTA:7-61 古风排版 (20分)--解析

7-61 古风排版 (20分)

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:
输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:
按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。

输入样例:
4
This is a test case

输出样例:
asa T
st ih
e tsi
ce s

解析见代码:

#include <bits/stdc++.h>
using namespace std;
char a[1100][1100];

int main(){
	int n,cnt=0;
	string s;
	cin >> n;
	getchar();
	getline(cin, s);	
	int k = ceil((double)s.size()/n);  //上取整 
	for(int j=k-1; j>=0; j--){
		for(int i=0; i<n; i++){
			if(cnt<s.size())a[i][j] = s[cnt++];
			else a[i][j]=' ';  //空格一定要补上
		}
	} 
	for(int i=0; i<n; i++){
		for(int j=0; j<k; j++){
			cout << a[i][j];
		}
		cout << endl;
	}
	return 0;
} 

在这里插入图片描述
欢迎大家批评改正!!!

发布了39 篇原创文章 · 获赞 2 · 访问量 3428

猜你喜欢

转载自blog.csdn.net/weixin_43581819/article/details/103978553