L1-039 古风排版(20 分)

L1-039 古风排版(20 分)
中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)

输入样例:

4
This is a test case
输出样例:

asa T
st ih
e tsi
ce s

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int main()
{
    int n,m;
    scanf("%d",&n);
    getchar();
    char s[1001],a[101][101];
    gets(s);
    int len=strlen(s),t=0;
    m=(len+n-1)/n;
    for(int j=m-1;j>=0;j--)
    {
        for(int i=0;i<n;i++)
        {
            if(t<len) a[i][j]=s[t++];
            else
                a[i][j]=' ';
        }
    }
    for(int j=0;j<n;j++)
    {
        for(int i=0;i<m;i++)
            printf("%c",a[j][i]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hy971216/article/details/80436605