7-6 古风排版 (20分)

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。
输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。

输入样例:

4
This is a test case

输出样例:

asa T
st ih
e tsi
 ce s
#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
using namespace std;
int main() {
    
    
     int n;
     cin>>n;
     string s;
     getchar();//清除缓冲
     getline(cin,s);
     int l;
     int len=s.length();
     if(len%n==0){
    
    
     	l=len/n;
	 }
	 else{
    
    
	 	l=len/n+1;
	 }
	 int i,j,k=0;
	 char a[200][5555];
	 for(i=0;i<n;i++){
    
    
	 	a[i][0]=' ';
	 }
	 for(i=l-1;i>=0;i--){
    
    
	 	for(j=0;j<n;j++){
    
    
	 		a[j][i]=s[k++];
	 		if(k==len){
    
    
	 			break;
			 }
		 }
	 }
	 for(i=0;i<n;i++){
    
    
	 	for(j=0;j<l;j++){
    
    
	 		cout<<a[i][j];
		 }
		 cout<<endl;
	 }
}

猜你喜欢

转载自blog.csdn.net/weixin_45962741/article/details/113107263