《算法笔记》9.2小节——数据结构专题(2)->二叉树的遍历->问题A:复原二叉树

问题 A: 复原二叉树

时间限制: 1 Sec  内存限制: 32 MB
提交: 535  解决: 332
[提交][状态][讨论版][命题人:外部导入]

题目描述

小明在做数据结构的作业,其中一题是给你一棵二叉树的前序遍历和中序遍历结果,要求你写出这棵二叉树的后序遍历结果。

输入

输入包含多组测试数据。每组输入包含两个字符串,分别表示二叉树的前序遍历和中序遍历结果。每个字符串由不重复的大写字母组成。

输出

对于每组输入,输出对应的二叉树的后续遍历结果。

样例输入

DBACEGF ABCDEFG
BCAD CBAD

样例输出

ACBFGED
CDAB

[提交][状态]

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<string>
using namespace std;

const int maxn=50;
struct node{
	char data;
	node *lchild;
	node *rchild;
};
string pre,in;

node *create(int preL,int preR,int inL,int inR){
	if(preL>preR)
		return NULL;
	node *root=new node;
	root->data=pre[preL];
	
	int k;
	for(k=inL;k<=inR;k++)
		if(in[k]==pre[preL])
			break;
	int numLeft=k-inL;
	
	root->lchild=create(preL+1,preL+numLeft,inL,k-1);
	root->rchild=create(preL+numLeft+1,preR,k+1,inR);
	
	return root;
}

void postorder(node *root){
	if(root==NULL){
		return;
	}
	postorder(root->lchild);
	postorder(root->rchild);
	printf("%c",root->data);
}

int main(){
	while(cin>>pre>>in){
		node *root=create(0,pre.size()-1,0,in.size()-1);
		postorder(root);
		printf("\n");
	}
	return 0;
}

发布了51 篇原创文章 · 获赞 7 · 访问量 7458

猜你喜欢

转载自blog.csdn.net/Jason6620/article/details/103988901