XHXJ's LIS HDU - 4352(LIS,数位dp)

#define xhxj (Xin Hang senior sister(学姐))
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life:
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year’s summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world’s final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world’s final(there is only one team for every university to send to the world’s final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo’s, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, “this problem has a very good properties”,she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: “Why do not you go to improve your programming skill”. When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don’t black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k… It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<2 63-1 and 1<=K<=10).
Output
For each query, print “Case #t: ans” in a line, in which t is the number of the test case starting from 1 and ans is the answer.
Sample Input
1
123 321 2
Sample Output
Case #1: 139

很有意思的题目,将我LIS的理解扩展到二进制去了

题意:
找出范围内LIS长度为k的序列
思路:
求LIS的nlogn算法为定义dp[len],代表长度为len的lis序列,最后一位最小值为dp[len]。
如果放到二进制当中,就是对于x,如果x-1位二进制后有1,那么去掉这个1,在x位填上1,相当于把dp[len]更新为较小值。如果x-1位后没有1,那么LIS值加加,并且把x位赋值为1。

之后再常规二进制判断即可;注意判断前导0,有前导0不能进行LIS处理。

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long ll;

ll dp[20][(1 << 10) + 10][20];
int digit[20];
ll K;

ll cal(ll s,ll &k,ll x)
{
    int pos = -1;
    for(ll i = x;i <= 9;i++)
    {
        if(s & (1 << i))
        {
            pos = i;
            break;
        }
    }
    if(pos == -1)
    {
        k++;
        s |= (1 << x);
    }
    else
    {
        s ^= (1 << pos);
        s |= (1 << x);
    }
    return s;
}


ll dfs(ll len,ll s,ll k,ll limit,ll lead)
{
    if(len == 0)
    {
        return k == K;
    }
    if(!limit && dp[len][s][K] != -1)return dp[len][s][K];
    int up = limit ? digit[len] : 9;
    ll ans = 0;
    for(int i = 0;i <= up;i++)
    {
        ll tmps = s,tmpk = k;;
        if(i == 0 && lead)
        {
            tmps = 0;
        }
        else
        {
            tmps = cal(tmps,tmpk,i);
        }
        ans += dfs(len - 1,tmps,tmpk,i == up && limit,lead && i == 0);
    }
    return limit ? ans : dp[len][s][K] = ans;
}

ll solve(ll x)
{
    ll len = 0;
    while(x)
    {
        digit[++len] = x % 10;
        x /= 10;
    }
    return dfs(len,0,0,1,1);
}

int main()
{
    memset(dp,-1,sizeof(dp));
    int T;scanf("%d",&T);
    int kase = 0;
    while(T--)
    {
        ll a,b;scanf("%lld %lld %lld",&a,&b,&K);
        printf("Case #%d: ",++kase);
        printf("%lld\n",solve(b) - solve(a - 1));
    }
    return 0;
}

发布了628 篇原创文章 · 获赞 17 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/tomjobs/article/details/104057464
今日推荐