【acm2629】 Identity Card

**题目:
Problem Description
Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it.
Here is the codes which represent the region you are in.
However,in your card,maybe only 33 appears,0000 is replaced by other numbers.
Here is Samuel’s ID number 331004198910120036 can you tell where he is from?The first 2 numbers tell that he is from Zhengjiang Province,number 19891012 is his birthday date (yy/mm/dd).

Input
Input will contain 2 parts:
A number n in the first line,n here means there is n test cases. For each of the test cases,there is a string of the ID card number.

Output
Based on the table output where he is from and when is his birthday. The format you can refer to the Sample Output.

Sample Input
1
330000198910120036

Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
代码:**

#include<iostream>

#include<string>

using namespace std;
string s;
int main(){
	string region,day,month,year;
	int k;
	cin>>k;
	 getline(cin,s);//用于吸收换行 
	while(k--){
		
	    getline(cin,s); 
		string str=s.substr(0,2);
		if(str=="33"){
			region="Zhejiang";
		}else if(str=="11"){
			region="Beijing";
		}else if(str=="71"){
			region="Taiwan";
		}else if(str=="81"){
			region="Hong Kong";
		}else if(str=="82"){
			region="Macao";
		}else if(str=="54"){
			region="Tibet";
		}else if(str=="21"){
			region="Liaoning";
		}else if(str=="31"){
			region="Shanghai";
		}
		year=s.substr(6,4);
		month=s.substr(10,2);
		day=s.substr(12,2);
		cout<<"He/She is from "<<region<<",and his/her birthday is on "<<month<<","<<day<<","<<year<<" based on the table."<<endl;
	}
	return 0;
}

分析:这一题关键在于输入字符串之前要处理掉输入k之后的那个换行,否则会留在缓冲区影响结果。

发布了42 篇原创文章 · 获赞 18 · 访问量 411

猜你喜欢

转载自blog.csdn.net/weixin_42918559/article/details/104021140
今日推荐