【PAT】1125 Chain the Ropes (25 分) - 排序

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题意:给N条绳子,要求把它们全部连起来,两条绳子连起来后的长度是原长度之和的一半 ,求N条绳子连起来所能达到的最大长度。

分析:一开始用的dfs,超时。后来一想发现短的绳子最先连起来得到的就是最长的,因为越早加入的绳子,对折的次数越多,所以要把长的绳子放在后面,让它对折次数尽可能的少。根据这个思路把绳子长度从小到大排序,然后从头到尾依次相加就能得到最大长度了。

#include <iostream> 
#include <algorithm>
#include <vector>
using namespace std;
vector<int> v;
int main() {
	int n, i, sum = 0;
	scanf("%d",&n);
	v.resize(n);
	for(i = 0; i < n; i++) 
		scanf("%d",&v[i]);
	sort(v.begin(),v.end());
	for(i = 1, sum = v[0]; i < n; i++ ) {
		sum = (sum + v[i])/2.0;
	}
	printf("%d",(int)sum);
	return 0;
}

用multiset也可:

#include <iostream>  
#include <set>
using namespace std;
multiset<int> v;
int main() {
	int n, data;
	scanf("%d",&n );
	for(int i = 0; i < n; i++) {
		scanf("%d",&data);
		v.insert(data);
	}
	auto it = v.begin();
	double sum = *it;
	for( it++; it != v.end(); it++ ) {
		sum = (sum + *it)/2.0;
	}
	printf("%d",(int)sum);
	return 0;
}
发布了30 篇原创文章 · 获赞 26 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_36032963/article/details/88797274
今日推荐