蒟蒻的ACM算法(五)-KMP算法

蒟蒻的ACM算法五-KMP算法


蒟蒻学识浅陋,欢迎各位大牛指正

KMP从入门到放弃

请观左神为什么想要杀人%%%%njb7
着重听1h12m20s
KMP分为两个部分,一部分为两个字符串间的比较,另一部分为自己与自己的比较.
简单的划分为下面两个图,详细理解请见左神不稳定情绪讲解.
1
2
不过我jiao的在1:21:04时,将例子换为"ababcababak"更好理解
3

代码

#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stdio.h>
#include<stdlib.h>
#ifndef NULL
#define NULL 0
#endif
using namespace std;

char t[1000100],s[1000100];
int len1, len2,n[1000100];
void KMP(char *s,char *t)
{
	for (int i = 0, j = -1; i < len1; i++) {
		while (j != -1 && t[j + 1] != s[i])
			j = n[j];
		if (t[j + 1] == s[i])
			j++;
		if (j == len2 - 1) {
			cout << i - len2 + 2 << endl;
			j = n[j];
		}
	}
}
void getnext(char *t)
{
	n[0] = -1;
	for (int i = 1, j = -1; i < len2; i++) {
		while (j != -1 && t[i] != t[j + 1])
			j = n[j];
		if (t[i] == t[j + 1])
			j++;
		n[i] = j;
	}
}
int main()
{
	cin >> s >> t;
	len1 = strlen(s);
	len2 = strlen(t);
	getnext(t);
	KMP(s, t);
	for (int i = 0; i < len2; i++)
		cout << n[i]+1 << ' ';
	return 0;
}

例题

G Oulipo
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

解析
kmp模板,读入不能用cin,否则超时

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<stdio.h>
#include<stdlib.h>
#ifndef NULL
#define NULL 0
#endif
using namespace std;

typedef long long ll;
char t[1000100], s[1000100];
int len1, len2, n[1000100];
ll read()
{
	ll f = 1,x = 0;
	char s = getchar();
	while (s<'0' || s>'9') {
		if (s == '-')
			f = -1;
		s = getchar();
	}
	while (s >= '0'&&s <= '9') {
		x = x * 10 + s - '0';
		s = getchar();
	}
	x *= f;
	return x;
}
int KMP(char *s, char *t)
{
	int ans = 0;
	for (int i = 0, j = -1; i < len1; i++) {
		while (j != -1 && t[j + 1] != s[i])
			j = n[j];
		if (t[j + 1] == s[i])
			j++;
		if (j == len2 - 1) {
			ans++;
			j = n[j];
		}
	}
	return ans;
}
void getnext(char *t)
{
	n[0] = -1;
	for (int i = 1, j = -1; i < len2; i++) {
		while (j != -1 && t[i] != t[j + 1])
			j = n[j];
		if (t[i] == t[j + 1])
			j++;
		n[i] = j;
	}
}
int main()
{
	int m;
	m = read();
	while (m--) {
		memset(n, 0, sizeof(n));
		scanf("%s %s", &t, &s);
		len1 = strlen(s);
		len2 = strlen(t);
		getnext(t);
		cout<<KMP(s, t)<<endl;
	}
	return 0;
}
发布了62 篇原创文章 · 获赞 13 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/UnKfrozen/article/details/84349304
今日推荐