hdu1018 Big Number(求n的阶乘的位数)

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41789    Accepted Submission(s): 20498


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
 
  
2 10 20
 

Sample Output
 
  
7 19
 知识点:

1:用 log 要带上头文件#include <math.h>

2: 一个正整数a的位数是(int)log10(a) + 1;
推导:对于任意一个给定的正整数a,
假设10^(x-1)<=a<10^x,那么显然a的位数为x位,
又因为
log10(10^(x-1)) <= log10(a) <(log10(10^x))
即x-1 <= log10(a) <x
则(int)log10(a)=x-1,
即(int)log10(a)+1=x
即a的位数是(int)log10(a)+1

3:先定义 double w;(w代表n的阶乘的位数,要定义成double,因为下面的斯特林公式计算出来的是实数)

斯特林公式是:w=log10(n!)=1.0/2*log10(2*PI*n)+n*log10(n/e)

实际上此处还不是n的阶乘,应该输出(int)w+1,因为加入w等于4.3568,那么实际上n的位数是5,所以我们强制类型转换一下,只保留整数位4,然后再加个1即可。

#define PI 3.141592654

#define e 2.71828182

《法一》(用公式(int)log10(a)+1):

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int main()
{
    int t,i,n;
    double w;
    scanf("%d",&t);
    while(t--)
    {
            scanf("%d",&n);
            w=1;
            for(i=1;i<=n; i++)
            w=w+log10(i);
            printf("%d\n",(int) w);
    }
    return 0;
}
关键步骤的解释
 for(i=1;i<=n; i++)
            w=w+log10(i);

这个是把公式化简了

log10(n!)+1=log10(1*2*3...*n)+1=(log10.1+ log10.2+log10.3....log10.n)+1;

《法二》(用斯特林公式)

#include <stdio.h>
#include <math.h>
#define PI 3.141592654
#define e 2.71828182
int main()
{
    int t,n;
    double w;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        w=(1.0/2*log10(2*PI*n)+n*log10(n/e));
        printf("%d\n",(int)w+1);//输出一定要注意int...然后+1
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/nanfengzhiwoxin/article/details/80259876
今日推荐