Big Number(阶乘的位数)

题目出处(点击)
Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19
思路:
直接找前人总结的结论,套用求阶乘位数

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
	int n,m,sum;
	double t;
	cin >> n;
	for(int i = 0; i < n; i++)
	{
		sum = 0;
		t = 0.0;
		cin >> m;
		for(int j = 2; j <= m; j++)		//公式记好 
		{
			t = t+log10(j);
		}
		sum = (int)t+1;
		cout << sum << endl;
		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_46687179/article/details/105623564