Slim Span(创新最小生成树问题)

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.
在这里插入图片描述

Figure 5: A graph G and the weights of the edges
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).
在这里插入图片描述

Figure 6: Examples of the spanning trees of G
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), © and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input
The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m
a1 b1 w1

am bm wm
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output
For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0
Sample Output
1
20
0
-1
-1
1
0
1686
50
题意:给你n个点,m条边,让你从m条边中选n-1条边形成连通图。连通图上最大的边权-最小的的边权为细度。求最小细度。
题解:对每个边都求一次以这个边为最小值的最小生成树。然后取到n-1条边的时候,让第n-1条边减去始边。
注意不能构成最短路的情况.

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define ll long long
#define MT(a,b) memset(a,b,sizeof(a))
const int maxn=1E2+5;
const int ONF=-0x3f3f3f3f;
const int INF=0x3f3f3f3f;
int n,m;
int pre[maxn];
int unionsearch(int root)
{
    int son=root,tmp;
    while (root!=pre[root])
        root=pre[root];
    while (son!=root)
    {
        tmp=son;
        son=pre[son];
        pre[tmp]=root;
    }
    return root;
}
void join (int x,int y)
{
    if (unionsearch(x)!=unionsearch(y))
        pre[unionsearch(x)]=unionsearch(y);
}
struct node
{
    int from,to,val;
}qwe[maxn*maxn];
bool cmp(node a,node b)
{
    return a.val<b.val;
}
int new_Kruskal(int eresting)
{
    int num=0,ans=INF;
    for (int i=1;i<=n;i++)
        pre[i]=i;
    for (int i=1;i<=m;i++)
    {
        int x=qwe[i].from;
        int y=qwe[i].to;
        if (unionsearch(x)!=unionsearch(y)&&qwe[i].val>=eresting)
        {
            join(x,y);
            num++;
            if (num==n-1)
            {
                ans=qwe[i].val-eresting;
                break;
            }
        }
    }
    if (num<n-1)
        return -1;
    else
        return ans;
}
int main ()
{
    int a,b,c;
    while (~scanf ("%d%d",&n,&m))
    {
        if (m==0&&n==0)
            break;
        for (int i=1;i<=m;i++)
        {
            scanf ("%d%d%d",&a,&b,&c);
            qwe[i].from=a;
            qwe[i].to=b;
            qwe[i].val=c;
        }
        int ans=INF;
        sort(qwe+1,qwe+1+m,cmp);
        for (int i=1;i<=m;i++)
            if (new_Kruskal(qwe[i].val)!=-1)
                ans=min(ans,new_Kruskal(qwe[i].val));
        if (ans==INF)
            printf ("-1\n");
        else
            printf ("%d\n",ans);
    }
    return 0;
}
发布了33 篇原创文章 · 获赞 15 · 访问量 922

猜你喜欢

转载自blog.csdn.net/weixin_43925900/article/details/96571794