Hackerrank - The Good Node

原题来自Careercup: http://www.careercup.com/question?id=5840928073842688

We have a list of N nodes with each node pointing to one of the N nodes. 

It could even be pointing to itself. We call a node ‘good’, 
if it satisfies one of the following properties: 

* It is the tail node (marked as node 1) 
* It is pointing to the tail node (node 1) 
* It is pointing to a good node 

You can change the pointers of some nodes in order to make them all ‘good’. 
You are given the description of the nodes. 
You have to find out what is minimum number of nodes that you have to change in order 
to make all the nodes good. 

Input: 
The first line of input contains an integer number N which is the number of nodes. 
The next N lines contains N numbers, 
all between 1 and N. 
The first number, is the number of the node pointed to by Node 1; 
the second number is the number of the node pointed to by Node 2;
the third number is the number of the node pointed to by Node 3 and so on. 

N is no larger than 1000. 

Output: 
Print a single integer which is the answer to the problem 

Sample Input 1: 







Sample output 1: 


Explanation: 
We have to change pointers for four nodes (node #2 to node #5) to point to node #1. 
Thus 4 changes are required 

Sample input 2: 







Sample output 2: 


Explanation: 
We have to just change node #5 to point to node #1 (tail node) which will make node #5 good. 
Since all the other nodes point to a good node (node #5), every node becomes a good node.

另外还需考虑4 4 3 2 1为输入的情况,输出应该是1.

这题用union-find(并查集,或者叫disjoint-set)来做。

import java.util.*;

public class GoodNode {
	public static int find(int[] parent, int x) {
        if(x == 0) return 0;
        if(parent[x] == -1 || parent[x] == x) {
            return x;
        }
        return find(parent, parent[x]);
    }
    
    public static void union(int[] parent, int x, int y) {
        int xp = find(parent, x);
        int yp = find(parent, y);
        parent[xp] = yp;
    }
    
    public static int minChanges(int[] A) {
        int n = A.length;
        int[] parent = new int[n];
        Arrays.fill(parent, -1);
        for(int i=0; i<n; i++) {
            union(parent, i, A[i]);
        }
        int cnt = 0;
        for(int i=1; i<n; i++) {
            if(find(parent, i) == i)
                cnt++;
        }
        return cnt;
    }
    
    public static void main(String args[] ) throws Exception {
        Scanner s = new Scanner(System.in);
        int n = s.nextInt();
        int[] A = new int[n];
        for(int i=0; i<n; i++) {
            A[i] = s.nextInt()-1;
        }
        s.close();
        System.out.println(minChanges(A));
    }
}

猜你喜欢

转载自yuanhsh.iteye.com/blog/2200515