【hackerrank】-Day 7: Arrays

30-arrays
Objective
Today, we’re learning about the Array data structure. Check out the Tutorial tab for learning materials and an instructional video!

Task
Given an array, , of integers, print ‘s elements in reverse order as a single line of space-separated numbers.

Input Format

The first line contains an integer, (the size of our array).
The second line contains space-separated integers describing array ‘s elements.

Constraints

, where is the integer in the array.
Output Format

Print the elements of array in reverse order as a single line of space-separated numbers.

Sample Input

4
1 4 3 2
Sample Output

2 3 4 1


Current Buffer (saved locally, editable)

#!/bin/python3

import math
import os
import random
import re
import sys



if __name__ == '__main__':
    n = int(input())
    arr = list(map(int, input().rstrip().split()))
    ss = ''
    for i in range(0,n):
        if i == n-1:
            ss = ss + str(arr[n-i-1])
        else:
            ss = ss + str(arr[n-i-1]) + ' '
    print(ss)

Congratulations!

You have passed the sample test cases. Click the submit button to run your code against all the test cases.

Testcase 0
Input (stdin)
4
1 4 3 2
Your Output (stdout)
2 3 4 1
Expected Output
2 3 4 1
Authorsaikiran9194
DifficultyEasy
Max Score30
Submitted By169305
NEED HELP?
View tutorial
View discussions
View editorial
View top submissions
RATE THIS CHALLENGE

MORE DETAILS
Download problem statement
Download sample test cases
Suggest Edits

猜你喜欢

转载自blog.csdn.net/langhailove_2008/article/details/81210918