POJ1287最小生成树

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12
0
Sample Output
0
17
16
26

思路:prim()算法求解,注意输入即可。

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAX=10010; 
const int INF=0x3f3f3f3f;
int cost[MAX][MAX];
int mincost[MAX];
bool used[MAX];
int V;
int prim(){
	memset(mincost,0,sizeof(mincost));
	for(int i=1;i<=V;i++){
		mincost[i]=INF;
		used[i]=false;
	}
	mincost[1]=0;
	int res=0;
	while(true){ 
		int v=-1;
		for(int u=1;u<=V;u++){
			if(!used[u]&&(v==-1||mincost[u]<mincost[v]))
				v=u;
		}
		if(v==-1)
			break;
		used[v]=true;
		res+=mincost[v];
		for(int u=1;u<=V;u++){
			mincost[u]=min(mincost[u],cost[v][u]);
		}
	}
	return res;
}
int main(){
	int p,r;
	int e1,e2,costA;
	while(1){
		cin>>p;
		if(p==0)
			break;
		cin>>r;
		if(r==0)
			cout<<"0"<<endl;
		else{
			for(int i=1;i<=p;i++)
				for(int j=0;j<=p;j++)
					if(i==j)
						cost[i][j]=0;
					else
						cost[i][j]=INF;
			V=p;
			for(int i=1;i<=r;i++){
				cin>>e1>>e2>>costA;
				if(cost[e1][e2]>costA)
					cost[e1][e2]=cost[e2][e1]=costA;
				//cost[e1][e2]=min(cost[e2][e1],costA);
			}
			cout<<prim()<<endl;
		}
	}
} 
/*样本输入
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
样本输出
0
17
16
26*/
发布了73 篇原创文章 · 获赞 27 · 访问量 1222

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/103927655