POJ 2349 最小生成树 Kruskal

Arctic Network
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 25406   Accepted: 7808

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

这个题题意有点难理解,s的意义理解了很久,意思就是说:有s个边之间用卫星通信,另外s-p个点之间用无线电通信,题目就是让你找出这s-p个点最小生成树的最大边。

附ac代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int pre[250005];
int t;
int n;
int p;
int tot;
double ans;
int cnt;
int find(int x)
{
    int root=x;
    while(root!=pre[root])
    {
        root=pre[root];
    }

    int i=x;
    int farther;
    while(pre[i]!=i)
    {
        farther=pre[i];
        pre[i]=root;
        i=farther;
    }
    return root;
}
bool jion(int a,int b)
{
    int ra=find(a);
    int rb=find(b);
    if(ra!=rb)
    {
        pre[rb]=ra;
        return true;
    }
    return false;
}
struct site
{
    int x,y;
    int no;
}s[505];
struct path
{
    site from,to;
    double len;
}a[250005];
bool cmp (path t1,path t2)
{
    return t1.len<t2.len;
}
double dis(site t1,site t2)
{
    return sqrt((t1.x-t2.x)*(t1.x-t2.x)+(t1.y-t2.y)*(t1.y-t2.y));
}
void Kruskal()
{
    ans=0;
    cnt=0;
    sort(a,a+tot,cmp);
   // for(int i=0;i<tot;++i)
       // printf("%.2lf %d %d\n",a[i].len,a[i].from.no,a[i].to.no);
    for(int i=0;i<=p;++i)
        pre[i]=i;
    for(int i=0;i<tot;++i)
        {
            if(jion(a[i].from.no,a[i].to.no)) ++cnt;
            if(cnt==p-n)
            {
                ans=a[i].len;
                break;
            }
        }

}
int ma[105][105];
int main()
{
    cin>>t;
    while(t--)
    {
        tot=0;
        scanf("%d%d",&n,&p);
        for(int i=0;i<p;++i)
            {
                scanf("%d%d",&s[i].x,&s[i].y);
                s[i].no=i+1;
            }
        for(int i=0;i<p;++i)
            for(int j=i+1;j<p;++j)
        {
            a[tot].from=s[i];
            a[tot].to=s[j];
            a[tot].len=dis(s[i],s[j]);
            ++tot;
        }
         Kruskal();
         printf("%.2f\n",ans);        //这个%.2f卡了很久,开始写的%.2lf。有没有哪位大佬知道为什么啊?评论区请留言

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codetypeman/article/details/80400616
今日推荐