hdu1548

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31001    Accepted Submission(s): 11132


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
 
  
5 1 5 3 3 1 2 5 0
 

Sample Output
 
  

3

#include<bits/stdc++.h>
using namespace std;
const int maxn = 205;
struct node{
	int level;
	int step;
	node(){
	}
	node(int level,int step)
	{
		this->level = level;
		this->step = step;
	}
};
int N, A, B; 
int lift[maxn];
int visit[maxn];
int bfs()
{
	queue<node> q;
	q.push(node(A,0));
	visit[A] = 1;
	while(!q.empty())
	{
		node t = q.front();
		q.pop();
		
		if(t.level == B) return t.step;
		
		int tmp1 = t.level + lift[t.level]; 
		if(tmp1 <= N && !visit[tmp1])
		{
			q.push(node(tmp1,t.step + 1));
			visit[tmp1] = 1;
		}
		int tmp2 = t.level  - lift[t.level];
		if(tmp2 >= 1 && !visit[tmp2])
		{
			q.push(node(tmp2,t.step + 1));
			visit[tmp2] = 1;
		}
	}
	return -1;
}
int main()
{
	while(cin >> N && N)
	{
		memset(visit,0,sizeof(visit));
		cin >> A >> B ;
		for(int i = 1;i <= N;i ++)
		cin >> lift[i];
		
		cout << bfs() << endl;
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80252383