HDU1548A strange lift

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31099    Accepted Submission(s): 11174


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
 
  
5 1 5 3 3 1 2 5 0
 

Sample Output
 
  
3
//ac
#include<iostream>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int dis[205],map[205][205],vis[205];
int data[205];
int n;
void Dij(int x)
{
	int pos=x,min;
	memset(vis,0,sizeof(vis));
	memset(dis,0,sizeof(dis));
	vis[pos]=1;
	for(int i=1;i<=n;i++) 
	{
		if(pos!=i)
		dis[i]=map[pos][i];
	}
	for(int i=0;i<n-1;i++)
	{
		min=inf;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j]&&min>dis[j])
			{
				pos=j;
				min=dis[j];
			}
		 } 
		 vis[pos]=1;
		 for(int j=1;j<=n;j++)
		 {
		 	if(!vis[j]&&map[pos][j]<inf&&(map[pos][j]+dis[pos]<dis[j]))
		 	dis[j]=map[pos][j]+dis[pos];
		 }
	}
}
int main()
{
	int a,b;
	while(cin>>n&&n)
	{
		cin>>a>>b;
		memset(map,inf,sizeof(map));
		for(int i=1;i<=n;i++)
		{ 
		cin>>data[i];
		if(i+data[i]<=n)//没有大于n的层数  
                map[i][i+data[i]] = 1;  
        if(i-data[i]>=1)//没有小于1的层数  
                map[i][i-data[i]] = 1; 
		} 
		Dij(a);
	    if(dis[b]>=inf)
	    cout<<"-1"<<endl;
	    else
	    cout<<dis[b]<<endl;  
	}
}

猜你喜欢

转载自blog.csdn.net/love20165104027/article/details/80369702