H: 奇数个的那个数

H: 奇数个的那个数
Submit Page Time Limit: 2 Sec Memory Limit: 128 Mb Submitted: 122 Solved: 46

Description
给定些数字,这些数中只有一个数出现了奇数次,找出这个数。

Input
每组数据第一行n表示数字个数,1 <= n <= 2 ^ 18 且 n % 2 == 1。
接下来n行每行一个32位有符号整数。

Output
出现奇数次那个数,每组数据对应一行。

Sample Input
5
1
1
2
2
3

7
1
2
1
2
2
3
3
Sample Output
3
2


map的使用,没有尝试迭代器。
map.find 返回迭代器,-> ,
没查到是end()
用for(x:map)然后 x.first
insert(make_pair());

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <cmath>
#include <algorithm>
#include <string>
#include <set>
#include <map>
using namespace std;

char s[10], c[10];
int A[1000000];
int main()
{
    int T;
    while (scanf_s("%d", &T) != EOF) {

        map<int,int> ss;
        for(int i=0;i<T;i++) {
            cin >> A[i];
            if (ss.find(A[i])!=ss.end()) {
                ss.find(A[i])->second++;
            }
            else ss.insert(make_pair(A[i], 1));
        }
        for (auto i : ss) {
            if (i.second %2== 1) {
                cout << i.first << endl;
                break;
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/sc_jn/article/details/80256327