奇数个的那个数(异或运算)

Description

给定些数字,这些数中只有一个数出现了奇数次,找出这个数。

Input

每组数据第一行n表示数字个数,1 <= n <= 2 ^ 18 且 n % 2 == 1。

接下来n行每行一个32位有符号整数。

Output

出现奇数次那个数,每组数据对应一行。

Sample Input

5
1
1
2
2
3

7
1
2
1
2
2
3
3

Sample Output

3
2

#include <iostream>
using namespace std;
int main() {
    int ans;
    int n, x;
    while(cin>>n) {
		ans = 0;
        while(n--) {
			cin>>x;
			ans^=x;
        }
		cout<<ans<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/adusts/article/details/80458837