【CodeForces 1249A --- Yet Another Dividing into Teams】

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_41879343/article/details/102695373

【CodeForces 1249A --- Yet Another Dividing into Teams】


Description

You are a coach of a group consisting of n students. The i-th student has programming skill ai. All students have distinct programming skills. You want to divide them into teams in such a way that:

No two students i and j such that |ai−aj|=1 belong to the same team (i.e. skills of each pair of students in the same team have the difference strictly greater than 1);
the number of teams is the minimum possible.
You have to answer q independent queries.

Input

The first line of the input contains one integer q (1≤q≤100) — the number of queries. Then q queries follow.

The first line of the query contains one integer n (1≤n≤100) — the number of students in the query. The second line of the query contains n integers a1,a2,…,an (1≤ai≤100, all ai are distinct), where ai is the programming skill of the i-th student.

Output

For each query, print the answer on it — the minimum number of teams you can form if no two students i and j such that |ai−aj|=1 may belong to the same team (i.e. skills of each pair of students in the same team has the difference strictly greater than 1)

Sample Input

4
4
2 10 1 20
2
3 6
5
2 3 4 99 100
1
42

Sample Output

2
1
2
1

解题思路

根据题意实际上只存在两种情况,有相邻的就是2,没有相邻的就是1,比如1,2,2,3就可以直接分为13,22.

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
const int MAXN = 105;
int arr[MAXN];

int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    int T;
    cin>> T;
    while(T--)
    {
        int n;
        cin >> n;
        for(int i=0;i<n;i++) cin >> arr[i];
        sort(arr,arr+n);
        int num=0,ans=1;
        for(int i=0;i<n-1;i++)
        {
            if(arr[i+1]-arr[i]==1)
                ans=2;
        }
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41879343/article/details/102695373