PTA 乙级——1032 挖掘机技术哪家强 C++实现

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_45677518/article/details/102076890

题目 挖掘机技术哪家强

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:
输入在第 1 行给出不超过 10^​5​​ 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:
在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

代码

#include <iostream>

using namespace std;

int main()
{

	int total;
	cin >> total;
	int total_score[100000] = { 0 };     //  对应的总分

	for (int i = 0; i < total; i++)
	{
		int team, score;
		cin >> team >> score;
		total_score[team] += score;
	}

	int max = 1;
	for (int i = 1; i < total; i++)     //   找到总分最大对应的max
	{
		if (total_score[max] < total_score[i])
			max = i;
	}
	cout << max << " " << total_score[max];

}

猜你喜欢

转载自blog.csdn.net/qq_45677518/article/details/102076890