(PAT Basic)1032.挖掘机技术哪家强(查找元素) C++

原题:https://pintia.cn/problem-sets/994805260223102976/problems/994805289432236032

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:
输入在第 1 行给出不超过 1 0 5 10^{5} 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:
在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:
2 150

题目分析:
用数组scores保存每个学校的编号对应的总分,在输⼊入时将每⼀一个分数score累加到学校编号id对应的scores[id]中,然后遍历整个数组,找到总分最大的元素位置即可。

#include <iostream>

using namespace std;


int main() {
	int N;
	cin >> N;
	int* scores = new int[N+1]; // 下标从1开始
	for (int i = 0; i <= N; i++) scores[i] = 0;
	int i;
	int id, score;
	for(i=0;i<N;i++){
		cin >> id >> score;
		scores[id] += score;
	}
	int max = 1;
	for (i = 2; i <= N; i++) {
		if (scores[i] > scores[max]) max = i;
	}
	cout << max << " " << scores[max] << endl;

	delete[] scores;
	system("pause");
}

猜你喜欢

转载自blog.csdn.net/Africa_South/article/details/88604720