PTA(Basic Level)1032.挖掘机技术哪家强

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第 1 行给出不超过 105 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0
输出样例:
2 150
思路
  • 用桶排的思想,将数组的下标堪称是序号,那么对用的位置加上向相应的成绩即可
代码
#include<bits/stdc++.h>
using namespace std;
int a[100010] = {0};
int main()
{
    int n;
    scanf("%d", &n);

    int id, score;
    int max_id = -1;
    while(n--)
    {
        scanf("%d%d", &id, &score);
        max_id = max(id, max_id);
        a[id] += score;
    }
    int ans_id;
    int ans_score = -1;
    for(int i=0;i<=max_id;i++)
    {
        if(a[i] > ans_score)
        {
            ans_score = a[i];
            ans_id = i;
        }
    }
    cout << ans_id << " " << ans_score;
    return 0;
}
引用

https://pintia.cn/problem-sets/994805260223102976/problems/994805289432236032

猜你喜欢

转载自www.cnblogs.com/MartinLwx/p/11606422.html