Harry And Dig Machine

Harry And Dig Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1991    Accepted Submission(s): 849


Problem Description
  As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm. 
  Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
 
Input
They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m. (1n,m50).
The next n line, each line contains m integer. The j-th number of ith line a[i][j] means there are a[i][j] stones on the jth cell of the ith line.( 0a[i][j]100 , and no more than 10 of a[i][j] will be positive integer).
 
Output
For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.
 
Sample Input
3 3 0 0 0 0 100 0 0 0 0 2 2 1 1 1 1
 
Sample Output
4 4
 
#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
const int maxn = 2e5 + 50;

int n, m;
int pos[maxn][36];
int dp[60][1000080];
int dis[1008][1008];

int main() {
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    while (scanf("%d%d", &n, &m) != EOF) {
        int cnt = 0;
        for (register int i = 1; i <= n; ++i) {
            for (register int j = 1, x; j <= m; ++j) {
                scanf("%d", &x);
                if (x || (i == 1 && j == 1)) {
                    pos[++cnt][0] = i;
                    pos[cnt][1] = j;
                }
            }
        }
        for(register int i=1;i<=cnt;++i){
            for(register int j=1;j<=cnt;++j){
                dis[i][j]=dis[j][i]=abs(pos[i][0]-pos[j][0])+abs(pos[i][1]-pos[j][1]);
            }
        }
        int tot = (1 << cnt);
        for (register int i = 1; i <= cnt + 1; ++i) {
            for (register int j = 0; j <= tot; ++j) {
                dp[i][j] = INT_MAX / 2;
            }
        }
        dp[1][0] = 0;
        for(register int i=0;i<tot;++i){
            for(register int j=1;j<=cnt;++j){
                if(dp[j][i]==INT_MAX/2)continue;
                for(register int k=1;k<=cnt;++k){
                    if(i&(1<<(k-1)))continue;
                    dp[k][i|(1<<(k-1))]=min(dp[k][i|(1<<(k-1))],dp[j][i]+dis[j][k]);
                }
            }
        }
        printf("%d\n",dp[1][tot-1]);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/czy-power/p/11488120.html
dig